今回のJetpackアップデートはWordPressが動かなくなる

投稿日:

 Jetpackが6.3.2になった。

 そこですぐにアップデートした。途端に、このブログは動かなくなった。下のようなエラーを吐いて、ブログが表示されなくなるのだ。

Parse error: syntax error, unexpected '[', expecting ')' in /home/ ... (中略) ... /wp-content/plugins/jetpack/modules/widgets/simple-payments.php on line 220

 このエラーが出る理由は簡単で、PHPのバージョンが古いからである。私の場合は5.x版のPHPを使用していたため、こういうことになった。

 PHPをサクッと7.1にアップデートすれば、このエラーは出なくなる。

 この状況は、一にかかって、環境によるとしか言いようがないが、ごくごく一例として、私が使用しているGMOペパボ(株)の「ロリポップ!レンタルサーバー」の場合を言えば、「ユーザ専用ページ」を表示させ、画面左ペインから「PHP設定」を選べばよい。そうすると、ドメイン毎にどのPHPバージョンを使用したいか選択できるようになる。ここで、全てのドメインにおいて最新のPHPバージョンを使用するよう設定すれば、今回の問題は即解消する。

 ただし、いわでもがなのことではあるが、自ら古いバージョンのPHP仕様に依存する諸設定や開発を行っている場合は上記の限りではなく、ましてや使用しているサーバが異なれば処置も全く異なる。私佐藤俊夫としてもかかる状況を踏まえた上での責任など()いかねるので、読者諸兄姉におかれてこの点を諒として頂きたい。

コメントを残す

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください